Amek Big 44 Power Supply problems

Graham Langley founded Amek in 1973 with Nick Franks. Since then, AMEK and TAC recording consoles have been the choice of demanding audio professionals for over 25 years.

Moderator: Matt Syson

Amek Big 44 Power Supply problems

Postby analogtodd » Fri Oct 07, 2016 5:24 pm

Ok,
Spent quite a bit of time reading through stuff before posting this, but I've got an Amek Big 44 with 2 850 power supplies. I've cleaned up/recapped both of them. Power supply 'A' works great. Connected to the console, I was able to trim +/- to 17.5 and 5volts and 48volts all look good. Had audio up and tested center section and modules no problem.

Power Supply 'B' on the other hand seems to be a problem. It first fired up, and I tested good voltages, I then plugged it into the console using the same cable as the first power supply... It immediately blew the + rail. Turned it off, replaced the fuse on the + side and tried again, same thing. I then replaced all the LM338 and the 2955. With no load (not plugged into console), I see good voltages. Plugging into console instantly blew both rails...

I've checked everything including the ground connections in the sockets of the regulators, everything appears to be good. I don't have a schemo/manual yet, so I'm flying a bit blind, but I do have a known good PS to test against and compare, and I just don't see anything!

I've rebuilt many, many MCI power supplies and this doesn't seem nearly as problematic, so I'm a little stumped here...
analogtodd
Analog Owner
 
Posts: 2
Joined: Fri Oct 07, 2016 4:06 pm

Re: Amek Big 44 Power Supply problems

Postby jensenmann » Sun Oct 09, 2016 5:10 am

It seems that the desk is the problem. Measure your desk´s power inlet of the faulty rail with an ohmmeter if there´s a short or very low resistance to ground. If so then pull channels one after another and measure the same. If the short disappears with a certain channel pulled then you know the troublemaker. If everything is pulled and the fault is still there then you need to check the frame the frame.
Jens
jensenmann
Yacht Rocker
 
Posts: 260
Joined: Wed Jan 31, 2007 6:08 am
Location: Karlsruhe, Germany

Re: Amek Big 44 Power Supply problems

Postby analogtodd » Tue Oct 11, 2016 9:09 pm

The other power supply, using the same cable, works just fine. I was able to test modules and everything looks good. Thats what leads me back to the power supply itself.
analogtodd
Analog Owner
 
Posts: 2
Joined: Fri Oct 07, 2016 4:06 pm

Re: Amek Big 44 Power Supply problems

Postby Matt Syson » Thu Oct 13, 2016 11:57 am

Hi
There is nothing inherently 'wrong' with the supply design, there are many thousands of these around the world so it suggests you have 'forgotten' something, such as insulation washers or you have swapped the wires on the board to EP8 connector.
The design is only a small variation from a National Semiconductor application note.
Matt S
Matt Syson
Engineer
 
Posts: 1028
Joined: Sun Oct 08, 2006 6:04 am
Location: North UK


Return to AMEK & TAC Recording Consoles

Who is online

Users browsing this forum: No registered users and 1 guest

 
Mr Patchbay sells patchbays, tt/bantam cables and more