850 Series Power Supply question

Graham Langley founded Amek in 1973 with Nick Franks. Since then, AMEK and TAC recording consoles have been the choice of demanding audio professionals for over 25 years.

Moderator: Matt Syson

850 Series Power Supply question

Postby SeldomSeenTrev » Fri Oct 06, 2017 2:37 pm

I've just recapped the 850 PSU for my Amek Big 28. While I was in there, I noticed some resistors attached to the J6 connection. It looks like an add on. It's overheated and the cable, resistors and connection are quite corroded. I'll cut the cable back a bit, and get some new resistors and reconnect but can anyone tell me what these are ? Why have they been added ? Also the colouring on the resistors is gone, so I'm not sure what values they are. Any suggestions ? Images are attached.

Another thing is I measured the voltages coming out of the PSU with the desk attached.
It's reading
-17.2v
+17.7v
5.5v
40.9v

Am I good to just trim these up to what they should be with the VR's on the board ? They're all pretty close but that 48v line reading 40.9v seems quite low.

Thanks
IMG_5305.JPG

IMG_5305.JPG
Attachments
IMG_5306.JPG
SeldomSeenTrev
Analog Enthusiast
 
Posts: 8
Joined: Sun Aug 27, 2017 7:02 pm

Re: 850 Series Power Supply question

Postby SeldomSeenTrev » Wed Oct 11, 2017 10:09 am

So I ended up tweaking the voltages inside the PSU.

I'm now reading + and - 17.5 exactly, +5.1v but my 48v line is still +40.9 and the VR is all the up.

Any one have any ideas why that is, and again any ideas what those resistors are for in my previous post ?

Many thanks...
SeldomSeenTrev
Analog Enthusiast
 
Posts: 8
Joined: Sun Aug 27, 2017 7:02 pm

Re: 850 Series Power Supply question

Postby AnalogStudio7 » Sat Oct 21, 2017 1:27 pm

I don't have an answer for your. But the AMEK power supply gurus in the USA is GRS.

Give them a shout for some help. info@grssystems.com www.grssystems.com

I'm sure they can help you out.

Cheers, Greg
AnalogStudio7
Lake Forest, CA 92630
USA
AnalogStudio7
Yacht Rocker
 
Posts: 155
Joined: Sat Feb 24, 2007 2:37 pm
Location: Lake Forest, CA 92630, USA

Re: 850 Series Power Supply question

Postby burtoni » Tue Oct 31, 2017 5:09 pm

i think those resistors may be dropping your extra volts. Definitely someone has modded for some reason.. also removed the fuse next to it.
burtoni
Analog Owner
 
Posts: 3
Joined: Tue Sep 12, 2017 2:41 pm


Return to AMEK & TAC Recording Consoles

Who is online

Users browsing this forum: No registered users and 8 guests

cron
 
Mr Patchbay sells patchbays, tt/bantam cables and more